11月 142011
 

以前に一回「USB 無線 LAN 色々、FreeBSD で試してみた。」と言うエントリを書いているのですが今回のその続編。二回目です。

今回は FreeBSD のバージョンを 9.0-RC1 にして、新たに購入した機器の動作確認をしてみました。とわいつつ、実は前回も書いているのですが、if_run と if_rum の機器を持ってくればほとんどが動作するんですけどねぇ・・。

今回試した USB 無線 LAN 機器は以下の通り。まずは写真を。

IMG_2549_RadioLan2_1.jpg

順番に見ていくとしましょう。

1. Planex GW-USNano2-G
写真の上のほうにある黒くてチッコイやつです。こいつは FreeBSD で動作しない、ドライバが書かれていない、例の Realtek RTL8192CU を使っているヤツです。またまたま買ってしまい大失敗しました・・。orz。 NetBSD だと動作するんですけどねぇ。

で、今回も ndis でトライしてみたんですが、USB 機器はどうしたら if_ndis に結びつけるのか結局解りませんでした。sys/dev/usb/usbdevs にエントリー書けば良いのかなぁ? ndis での USB 機器の使い方がいまいち解らないんですよねぇ。そんなデバイスは知らん。と言われて ugen にアタッチされてしまいます・・。orz。

2. Planex GW-US54Mini2
これはアキバの某お店で 499yen で売っていたので買ってきて試しました。 FreeBSD では if_rum で動作します。 802.11g でリンクアップするのでこれはまぁ、中々良い感じでしょうか。ただし、今はもう販売終了となっていると思いますが・・。

3. Logitec LAN-W300N/U2
これは FreeBSD では if_run で動作します。けっこう高速で利用できます。続きはちょっと下のほうで書きます。

4. BUFFALO WLI-UC-GNM
これも FreeBSD では if_run で動作します。802.11b/g/n に対応しているので 150Mbps 出る。と言われていますが、そこそこな感じでしょうか。

と、言うことで今回は四打数三安打でした。それにしても最近は ちっこい USB 無線 LAN アダプタが RealTek のだったり Ralink のだったりするので購入する場合にはちゃんと下調べしたほうが良いと思われます。

で、どうして今回、再度の検証を行なったかと言うと、以前利用していた PCI GW-US300MiniW が壊れてしまったので、手持ちであるあるやつを利用し始めたんだけどこいつらみんな遅いっ!! 例えば NFS 上にある動画を再生しようとするとブチブチコマ落ちするし止まるしで到底実用には耐えられない遅さなのであります。

じゃ。ってんで、今回二回目の買い出しに出たのであります。結論から言うは if_run でも通信速度が速いものと遅いものがあります。僕が思うに小さいのはアンテナの影響から来るのか、遅いですね。BUFFALO WLI-UC-GNM は小さくてスルっと収まるんだけど遅いのが難点。
Logitec LAN-W300N/U2 はちょっと出っ張るんだけど、こいつは速いです。WLI-UC-GNM よりも速い。あと、以前使っていて壊れてしまった GW-US300MiniW も大きくて邪魔だったんだけど速かった。

あ、体感的には if_rum よりも if_run のほうが速いですね。まぁ、これはチップとドライバの問題で、当然 if_run のほうが速いのだろうと思いますが。

と、言うわけで教訓。

・if_run を買いましょう。
・300M と書いてあるのは多分速い。けど、その分でかい。
・速さを求めるならでかいのを買いましょう。

って感じでしょうか。デバイスが認識したあとに ifconfig wlan0 の media の部分を見ると良いと思います。

さてさて。どうして僕がこんなに USB 無線 LAN アダプタに凝るのか? と言えば、ThinkPad X100e 内蔵の 無線 LAN カード Advanced-N + WiMAX 6250 が正常に動作しないので USB アダプタに走るのでありました。

が、この間別のエントリにコメントしました<が、Advanced-N + WiMAX 6250 は動作するようになりました。 ここに書かれているように if_iwn.c を改修すると動作します。

それにしてもちゃんと動作する if_iwn はむちゃくちゃ速いです。 802.11n でリンクアップします。実際に計測してみると 24,5Mbps は出ています。すげーーっ(@_o)。けど、しょっちゅう通信が切れるんですよね。リンクの up/down はしないんだけど 30 秒くらい平気で止まってしまい、利用できるんだけど実用には耐えられない。速いだけに非常にもったいない・・。orz

と、言うことで Advanced-N + WiMAX 6250 の次に速いのが GW-US300MiniW、その次が LAN-W300N/U2 です。こいつは 12,3Mbps くらい出てくれます。 WLI-UC-GNM になると if_rum の速い機器と同等程度の速度になりますかねぇ。

あくまでも僕の実測と体感からの感想です。

と、言うことで if_run が今のところは一番良い感じだと思います。利用できるのは当たり前。更に速度を求めるのであればもっと他に色々試してみたいものですねぇ;-)。

  6 件のコメント to “USB 無線 LAN 色々、FreeBSD で試してみた。そのに。”

  1. 初めまして。
    Logitec LAN-W300N/U2を購入したものの、うまく動かないので色々調べていたらこちらのブログにたどり着きました。
    run0、どうもうまく動きません・・・(FreeBSD 9.0 STABLE)
    firmwareはRT3071がロードされ、wpa_supplicantもexampleのwepの箇所に習って書いてみたのですが、うまくいきません・・・
    僕自身が、設定やらなんやらがわかっていないので、質問するにも情報が上げられないのですが、できれば接続に成功した時の設定ファイルや、今までハマったことなどを教えていただけたらと思います。

  2. 初心者bsdユーザさん。こんばんは。
    手元ではサクサクと動作しています。カーネルはGENERICカーネルなんでしょうかね?情報が全然無いので説明のしようが無いのですが、取り合えず以下のロードモジュールをロードするのが良いかと思われます。
    wlan_load=”YES”
    wlan_xauth_load=”YES”
    wlan_wep_load=”YES”
    wlan_tkip_load=”YES”
    wlan_ccmp_load=”YES”
    wlan_amrr_load=”YES”
    runfw_load=”YES”
    rt2561sfw_load=”YES”
    rt2661fw_load=”YES”
    rt2561fw_load=”YES”
    接続について、つまりは wpa_supplicant についてですが、WPA に接続したいのか WEP に接続したいのかも書かれていないので解りませんが LAN-W300N/U2 の動作確認をしたいのであれば認証がかかっていない AP を用意して /etc/rc.conf に以下のように書いてみてはいかがでしょうか。
    wlans_run0=”wlan0″
    ifconfig_wlan0=”DHCP ssid SS-ID”
    これで接続できるようになると LAN-W300N/U2 の動作は OK、カーネルモジュール OK となるので、あとは AP の認証を通過するための設定を入れるだけになります。
    もしかしたら AP で Mac アドレスフィルタ入れていたりして;-)。
    頑張ってください。

  3. 返答ありがとうございます。
    #本当に情報が少なくてすみません…GENERICカーネルでWepを使おうとしていました。
    アドバイス通り認証なしでつないでみたところ接続できるようになりました!
    ただ、認証なしのままwpa_supplicant.confを
    network={
    ssid=”myssid”
    key_mgmt=NONE
    }
    として、rc.confに
    wlans_run0=”wlan0″
    ifconfig_wlan0=”WPA DHCP”
    wpa_supplicant_enable=”YES”
    と記述しても動きませんでした…
    じゃあ、ということでrc.confに
    ifconfig_wlan0=”DHCP ssid myssid wepmode on wepkey hoge1 deftxkey 1″
    としてみてもだめでした。
    設定が違うのかなんなのか・・・
    ひとまず、アドバイス通りやってみたところうまく動いたので、無線ルータにMACアドレスフィルターを設定して使用することにしました。
    長々とコメントを書いてしまってすみませんでした;;

  4. 初心者bsdユーザさん。こんばんは。
    WEP 認証だと wpa_supplicant は利用せずとも /etc/rc.conf への設定だけで接続できると思いますよ。以下の設定でどうですか?
    wlans_run0=”wlan0″
    ifconfig_wlan0=”DHCP SS-ID wepmode on wepkey 0x313131313131 mode 11g weptxkey 1″
    wep キーは 16 進で記述してみてはどうでしょう。

  5. こんばんわ。
    何度もアドバイスしていただき、ありがとうございます。
    前回うまくいったので、今回も!と思ったのですが、だめでした・・・
    アドバイスのとおり設定した後、ifconfigを実行するとstatusはassociateと表示され、無線ルータ(emobileのGL01P)の接続台数も増加しているのでつながっているようには見えるのですが、DHCPでアドレスがうまくとれていないようです。
    DHCPがだめなのかなぁと思ってアドレス指定をしてみたのですが、それもうまく行かず…
    無線ルータ側の設定はノーガード→wepとしただけなので、FreeBSDの設定が正しければつながると思うのですが…なかなか難しいです
    (16進数が間違えているという寒いこともしてないはず・・・w)

  6. ご無沙汰しております。以前FreeBSDカーネルのスリム化でお世話になった者です。

    こちらの記事を参考に、FreeBSD 9.1-Releaseをインストールしたデスクトップ(samba 3.6をインストールして簡易ファイルサーバーにしてます)に、Logitec LAN-W300N/U2を買ってきて挿して、快適に使えるようになりました。

    Windows 7 Pro SP1のバックアップ先にも指定していますが、両方ともLAN-W300N/U2にすることで、バックアップも順調に進みました(Windows 7のほうを150MbpsのUSB無線LANアダプターにしていたときは、バックアップに失敗していました)。

    取り急ぎ、お礼まで。

 コメントを書いてください。

HTML タグが利用できます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <img localsrc="" alt="">

(必須項目)

(必須項目)

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)